Can't open editor

I’ve been trying to get Flax running on my laptop. I’ve followed the instructions specified here : Editor on Linux | Flax Documentation, except for updating the drivers (as recent versions of Blender & UE5 run fine).

The problem I’m having is that I can’t get the editor to open. Flax seems to be loading, but then shuts down again right after. I’ve tried creating a new project from the command line, and it seems to be generated, but again, the editor doesn’t open up.
There are log files inside the new project ; there do not seem to be any errors, but the last warning is about “not being able to load the windows layout from …/Editor/LayoutDefault.xml - closing splash screen”.

I’ve just recently switched to Linux, so I’m not sure how to continue. Any help would be highly appreciated.

EDIT : more info :
. $> vulkaninfo --summary :

warning : [Loader Message] Code 0 : loader_scan_for_direct_drivers: The VK_LUNARG_direct_driver_loading extension was enabled but the pNext chain of VkInstanceCreateInfo did not contain the VkDirectDriverLoadingListLUNARG structure

. laptop is set to use NVIDIA card
. $> ./FlaxEditor -project “/path/proj” -std -nvidia : same result
. laptop runs Godot4 (Vulkan) without problems
. Flax log file :

[ 00:00:02.857 ]: [Warning] Cannot load windows layout. File is missing
[ 00:00:02.857 ]: [Info] Loading editor windows layout from '/home/sc/s
[ 00:00:02.869 ]: [Info] Closing splash screen