Unable to run the Flax Engine as regular (non admin) user from the Launcher

I can’t install or run the Flax Engine as regular user (non admin rights) from the Launcher. I’ve installed the Launcher and run it as regular user. From there I add the Flax Engine to get installed, but then a pop up message says it needs admin righs to install the engine. Then it automatically restarts the Launcher with admin rights and installs the engine successfully (I am not using the default installation path, by the way).

So far, so good, but when I run the Launcher again as regular user, the Launcher does not “see” the engine installed.

I managed to run the engine as regular user by just avoiding the Launcher, and just running the FlaxEditor.exe and opening an existing project. I also can create new projects from the Launcher as regular user, but then, I can’t open them from the Launcher. Of course, if I run the Launcher as admin it “sees” the engine, but I don’t want to run any application with a privileged account.

The Launcher never “sees” the engine installed, but neither can’t install it as regular user because it needs admin rights. It seems I am in an endless loop here…

That’s a strange issue and might be related to file/folder privileges or rights on the system. Flax uses file Versions.txt in folder %appdata%/Flax/ to store the registry of installed engines. You could see if it contains a path to the engine installation.