First time opening Flax Engine error "Could not load file or assembly 'CefSharp.Core.dll'..."


I have just downloaded Flax Engine for the first time (Using Windows 10), when launching I get the above error:

Could not load file or assembly ‘CefSharp.Core.dll’ or one of its dependencies. The specified module could not be found.

After clicking OK Flax fails to open.

I’m pretty naïve but it seems that this issue can be mitigated for users that do not have the necessary libraries when compiling: Bug: Can not load file or assembly ‘CefSharp.Core.dll’ or one of its dependencies · Issue #850 · cefsharp/CefSharp (

So either the software itself needs recompiling or maybe the needed dll’s could be added with the installer?

Update: After some further looking, I can see that the cefSharp dll files are sitting in the Flax installed directory, so now I’m really not sure why it can’t find it. Is anyone else having this issue?

Maybe missing .Net Framework? We use .Net 4.5 as installed with Launcher. Requirements:

I already have Visual Studio 2019 installed on my PC and the .NET framework. I tried to run the installer from the link on the requirements page but got this while trying to install .NET both 4.0 and 4.5:

I also tried to install the Visual C++ Redistributable for Visual Studio 2015 as the requirements page says:


So not 100% sure what to try next, any ideas? Sorry to be a pain.

Ok sorry! But I just restarted my PC, it happened to do an update… and now it is working…

Who the hell knows what happened there :man_shrugging:

Thanks for your help.