Fullscreen mode in 1.7

a few problems I found in this release.
for info:
I have a relatively old development computer.
(Laptop with 12GB Ram and a 4GB gtx 950m GPU / DX12)

  1. Full screen only works with directX 11
    DirectX 12 shows a frameless window with the set resolution on the desktop. (so no full screen)

  2. in directX 11 the “full screen mode” works.
    “Full screen borderless” again only shows a frameless window on the desktop.

  3. in directX 11 “full screen mode”, it runs completely smoothly at a resolution of 1366 x 768.

Now comes the funny thing:
I have a scene with a forest and some objects and lighting effects.

When I walk into the forest (the camera sees a lot of objects) it runs smoothly.

When I go out of the forest (the camera sees few objects) it starts to jerk even though the frame rate remains at 60 fps.

Does anyone else have the problem?

Smooth when i walk in the forest: (many objects)

Lag when i come out of the forest: ( only 1 tree and a cliff )

I seem to have found the problem with the stuttering.

In the Nvidia settings I have to explicitly set the framerate to 60 frames and Vsync to on.
Otherwise the output seems to be somehow out of sync.

best regards


Be careful, because the stuttering problem can be unpredictable. I’ve also experienced stuttering with a simple, almost empty scene, and if I remember correctly I’ve also experienced it with vsync enabled (I’m thinking of enabling vsync within the flax project, not the gpu driver). However, this was completely unpredictable for me, that is, I tested it with the already cooked game, in full screen mode, and it varied, there were no stutters at some startups, but several times it did. The flax project comes with the following “Time Settings” by default:

Update FPS: 60
Physycs FPS: 60
Draw FPS: 60

The easiest way to solve stuttering is to make a small difference between Update FPS and Draw FPS. For example, if I changed the Draw FPS to 59.9, it never stuttered again. I tested all this with a 144Hz refresh rate. So it’s true that basically it wasn’t completely smooth, since the game rendered at 60FPS, but it wasn’t the extreme stuttering that I think you might have experienced. But if the Draw FPS is 60 and the Update FPS is 0 (that is, unlimited), then there are no stutters either. Or you can even turn off the Update and Draw limits completely if you set them to 0. You should also pay attention to the fact that many players do not play with 60Hz monitors. However, it is also not good if the Update FPS is lower than the Draw FPS. I think the final game should make it possible for players to override Draw FPS, or even turn off the limit completely, and to turn vsync on/off. Now I think that maybe the best default setting is to have Phisycs FPS 60, but Draw FPS and Update FPS unlimited. Vsync should be enabled by default in the game. Since the Update FPS is unlimited, I think it will never be exactly the same as the Draw FPS.
I hope I didn’t say something stupid, at least I experienced these things.

Thanks, I’ll give that a try